[phpBB version 3.0] Indications d'intégration complète

Aide à l'installation de la carte des membres
papicx
Messages : 11
Enregistré le : jeu. 31 mai 2012 8:30

Message par papicx » lun. 04 juin 2012 9:34

Bonjour à tous,
Chose promise, chose due :!:

Je vous mets ici le fichier install_papi.txt qui n'est en fait que le fichier install de Mika et Lionel qui tient compte de TOUTES les modifications/corrections émises par les posteurs, notamment joelencreuse, lechti64, joelausec.

Je les en remercie ici bien bas.

Image
et un fichier zip de capture d'écran : Image

mon fichier install_papi.txt contient des indications et installe des commentaires dans les fichiers modifiés. C'est plus facile ainsi lorsqu'on recherche un bourde ou bien lorsqu'on installe un autre mod par la suite.

J'ai installé ce mod à partir de ce fichier et ça marche sur mon forum en phpbb3.0.10.

Pour ceux qui ont converti leur forum de phpbb2 à la version phpbb3, il faut soit au moment de la conversion avoir pensé à convertir le champ cdm, comme tout champ personnalisé, à la version 3.

Si vous ne l'avez pas fait, comme moi :? , RIEN n'est perdu !
il faut faire ce qui suit : ( avis à ceux qui savent le faire automatiquement, on est preneur ! perso, ça m'a pris 30 minutes )

Allez sur votre partie admin de carte des membres,
Gestions des points/membres
Voir la liste des membres au format.csv
Enregistrer cette liste sur votre pc et imprimer cette liste .
( perso, j'en avais 3 pages )

Cette liste comporte en premier numéro, le numéro ID des utilisateurs suivi de leur positions GPS respectives , puis de leur pseudo.

Faites cette commande, comme c'est indiqué dans l'install.txt et install_papi.txt
Ouvrez votre navigateur et rendez-vous à la page suivante afin d'initialiser la base de données :

Code : Tout sélectionner

http://votre-site.com/cdm.php
Ensuite, allez sur la gestion de votre base de données chez votre hébergeur. c'est souvent PhpMyAdmin qui est installé.
Sélectionner votre base,
Descendez jusqu'à phpbb3_user. (enfin si c'est phpbb3 que vous avez mis en préfixe dans votre base, bien sûr).

Cliquez sur l'onglet "rechercher" et indiquez dans le champ user_id le numéro de la première ligne de votre liste csv.
Cliquez sur "executer", le bouton est tout en bas de page à droite sur PhpMyAdmin

Si le profil existe toujours, vous avez la ligne de l'utilisateur qui s'affiche.
sinon, vous avez un message vous indiquant qu'il n'a rien trouvé. ( notez le, il faudra, si vous le voulez, supprimer cet utilisateur sur la carte...

Dans le cas ou la ligne est trouvée, cliquez sur "modifier"
recherchez le champ "cdm" et modifiez le zéro en 1, puis cliquez sur "executer".

Voilà, la première ligne c'est un peu long, mais vous allez voir qu'on va les traiter par lot par un simple copier-coller...

Regardez bien la ligne qui s'est affichée après avoir cliqué.
vous avez un truc du genre :

Code : Tout sélectionner

UPDATE  `nom_de_la_base_de_donnee`.`phpbb3_users` SET  `cdm` =  '1' WHERE  `phpbb3_users`.`user_id` =5;
Le dernier numéro, vous l'avez compris, c'est celui de l'utilisateur qu'on a modifié.

Il vous suffit alors de faire des copier-coller par lot de 3 ou 5 par exemple en modifiant le numéro ID puis d'executer... et noter sur la feuille imprimée ceux que vous avez fait, ceux qui vous sont retournés avec un message d'erreur ( comptes supprimés sur votre forum).

Dans le cas ou vous faites une seconde fois la manip sur le même id, vous avez un message d'erreur vous disant qu'il n'a rien trouvé.
Vous pouvez vous en assurer en mettant un zéro à la place du "1" dans la ligne de commande

Code : Tout sélectionner

SET  `cdm` =  '0' 
Ainsi, vous savez que le compte existe et il suffit de recommencer en mettant un 1 à nouveau. :wink:


NB : je n'ai pas modifié le style subsilver2 car je ne l'ai pas. je ne peux donc pas le tester.

Il vous reste à supprimer les points des comptes absents de votre forum sur carte-des-membres.com si vous le voulez bien entendu.

Voilà, bon courage à tous.
Faites en bon usage.

MERCI MERCI MERCI Mika, et Lionel de ce super MOD :!:

TRUST
Messages : 3
Enregistré le : dim. 28 nov. 2010 14:07

Message par TRUST » dim. 10 juin 2012 0:57

Bonjour,

J'aimerai ajouter cette option, cependant j'ai fait cette modification sur notre forum:

http://forums.phpbb-fr.com/message1384877.html#p1384877

Est il possible de mettre le lien pour ce positionner sur la carte au même endroit? Si oui quelqu'un sait il ce que je dois modifier?

J'ai fait une première installation mais ça n'a pas fonctionné, j'ai eu un message d'erreur quand je suis allé à l'adresse monsite/cmd.php ??

Du coup j'ai supprimé tout les fichier installés et modifiés.

Invité

Message par Invité » dim. 10 juin 2012 22:26

Bonjour.
il diszit quoi ton messsage d'erreur ?

TRUST
Messages : 3
Enregistré le : dim. 28 nov. 2010 14:07

Message par TRUST » dim. 10 juin 2012 22:47

Zuutt, j'ai pas pensé à le noter :oops:

J'ai aussi installé un MOD sur notre forum, et je voudrais savoir si il est possible d'y mettre le lien pour ce localiser

Image

Lien du MOD ICI pour ceux qui veulent le voir de plus près.

Invité

Message par Invité » mar. 12 juin 2012 13:15

Bonjour
Pour l'installation d'un mod, il faut être TRES rigoureux.
Je paraphraserai une vieille pub : même les messages d'erreur veulent dire quelque chose...

Pour ce mod (cdm) il y a deux ou trois fichiers cdm.php

Ils ont le même nom, mais ils sont implantés dans différents dossiers et n'ont pas les mêmes lignes de code.
Reprends ton mod, applique mon install et tu verras ça marche du premier coup !
Ne saute aucun paragraphe dans l'install... prends ton temps.
à plus.
papi

papicx
Messages : 11
Enregistré le : jeu. 31 mai 2012 8:30

Message par papicx » mar. 12 juin 2012 13:21

OOUP'S je n'étais pas connecté. désolé.

Bonjour
Pour l'installation d'un mod, il faut être TRES rigoureux.
Je paraphraserai une vieille pub : même les messages d'erreur veulent dire quelque chose...

Pour ce mod (cdm) il y a deux ou trois fichiers cdm.php

Ils ont le même nom, mais ils sont implantés dans différents dossiers et n'ont pas les mêmes lignes de code.
Reprends ton mod, applique mon install et tu verras ça marche du premier coup !
Ne saute aucun paragraphe dans l'install... prends ton temps.
C'est quoi l'adresse de ton site ?
car il faut mettre http://TONSITE/cdm.php
Cette action contrôle/ajoute un champ dans ta base de données.
lis bien mon install, j'ai mis plein d'infos.
à plus.
papi

Invité

Message par Invité » dim. 18 nov. 2012 16:47

Le fichier install_papi.txt est il compatible avec un forum phpbb3 v3.0.11?

Merci d'avance

Invité

Message par Invité » ven. 12 juil. 2013 23:12

Bonjour.
Je pense que oui. Il faut que je regarde...

Lor@n
Messages : 7
Enregistré le : jeu. 22 août 2013 8:57

Message par Lor@n » jeu. 22 août 2013 9:07

Intégré sur mon forum en phpbb 3.0.11, avec l'install de papicx, impeccable sur Subsilver.

encore merci.

papicx
Messages : 11
Enregistré le : jeu. 31 mai 2012 8:30

Message par papicx » mar. 24 déc. 2013 11:17

Bonjour à tous,
Je n'avais pas contrôlé que quand on clique sur le point de la carte, le lien mène vers une page 404 (page non trouvée)
en fait, c'est tout simple, il faut corriger le lien qui pointe vers le membe dans les options de carte de membre.

allez dans l'administration de votre carte,
allez sur la page de configuration de la carte de membre avec vos codes : adresse e-mail + code
en étant connecté comme admin sur votre forum puis en allant sur la page carte de membre.com de votre site.

le lien de la page sera du style :

Code : Tout sélectionner

http://www.carte-des-membres.com/fr/nomdevotresitedonnéparcartedemembre/
en cliquant sur le tout petit lien "admin" en bas du cadre "options"

descendez au paragraphe "Gestion des points/membres :"
le lien vers le site en phpbb2 est de la forme :
http://www.mondomaine.extension/phpbb/profile.php?mode=viewprofile&u=--id--
il faut le modifier sous la forme :
Voilà,
Faites en bon usage. ;-)
NB je N'ai PAS modifié mon archive de conversion proposé plus haut.

Invité

Message par Invité » sam. 28 déc. 2013 10:34

papicx a écrit :

Faites cette commande, comme c'est indiqué dans l'install.txt et install_papi.txt
Ouvrez votre navigateur et rendez-vous à la page suivante afin d'initialiser la base de données :

Code : Tout sélectionner

http://votre-site.com/cdm.php
E
Bonjour,

Moi je bloque déjà à cette étape, ça me redirige vers la page d’accueil de mon forum...
Bon je précise que je suis vraiment pas doué pour tout ça, il n'existe pas un tuto en image, pas à pas ?

Merci d'avance :)

François

PS : mon forum : http://carna-oise.forumactif.org/

Invité

Message par Invité » dim. 29 déc. 2013 13:05

Bonjour.
Je vous ça cet am.

Invité

Message par Invité » dim. 29 déc. 2013 13:06

Bonjour .
Je vois ça cet am
Papicx

papicx
Messages : 11
Enregistré le : jeu. 31 mai 2012 8:30

Message par papicx » dim. 29 déc. 2013 15:15

Bon, pour faire concret, on te demande de faire ce lien.
http://carna-oise.forumactif.org/cdm.php et de cliquer dessus.

Ceci pour mettre en place (installer) le mod sur ton forum...

Mais d'abord as tu modifié les fichiers comme indiqué dans ton forum ?
Je te recommande vivement de faire ça avec Notepad++ (qui N'EST PAS le bloc note de Windows !).
Enregistre (CONVERTIR si ce n'est pas le cas) tes fichiers avec l'encodage UTF-8 sans BOM (menu encodage), et converti tes sauts de ligne en UNIX (menu édition).
Voilà, Pour tout autre aide, vois avec ton forum de support (forumactif).

carte-des-membres
Site Admin
Messages : 651
Enregistré le : mar. 28 déc. 2004 12:04
Localisation : 35
Contact :

Message par carte-des-membres » mar. 31 déc. 2013 11:44

"carna-oise" > Vous utilisez un système de forum "forumactif" qui est bien basé sur phpBB mais auxquels vous n'avez pas accès aux fichiers sources qui accessible par exemple en FTP.
Sans modification possible des scripts du forum, les inscriptions des membres sur la carte doit alors passer (au moins la création du lien) par un admin de la carte, voir le sujet suivant : viewtopic.php?t=28

Feneck91
Messages : 4
Enregistré le : ven. 11 oct. 2013 3:12

Message par Feneck91 » ven. 14 févr. 2014 10:24

Tout bien installé ! Parfait !
J'ai juste galéré pour mettre une icône dans la barre de navigation : j'ai du copier l'image manuellement dans un répertoires qui va bien car même en rafraichissant le cache / le pack d'image et le template, l'image ne s'affichait pas. Bizarre !

Lor@n
Messages : 7
Enregistré le : jeu. 22 août 2013 8:57

Message par Lor@n » mer. 26 févr. 2014 17:49

papicx a écrit :Bonjour à tous,
Je n'avais pas contrôlé que quand on clique sur le point de la carte, le lien mène vers une page 404 (page non trouvée)
en fait, c'est tout simple, il faut corriger le lien qui pointe vers le membe dans les options de carte de membre.

allez dans l'administration de votre carte,
allez sur la page de configuration de la carte de membre avec vos codes : adresse e-mail + code
en étant connecté comme admin sur votre forum puis en allant sur la page carte de membre.com de votre site.

le lien de la page sera du style :

Code : Tout sélectionner

http://www.carte-des-membres.com/fr/nomdevotresitedonnéparcartedemembre/
en cliquant sur le tout petit lien "admin" en bas du cadre "options"

descendez au paragraphe "Gestion des points/membres :"
le lien vers le site en phpbb2 est de la forme :
http://www.mondomaine.extension/phpbb/profile.php?mode=viewprofile&u=--id--
il faut le modifier sous la forme :
Voilà,
Faites en bon usage. ;-)
NB je N'ai PAS modifié mon archive de conversion proposé plus haut.
La modif était déja faite non? car pas de souci sous phpbb3

carte-des-membres
Site Admin
Messages : 651
Enregistré le : mar. 28 déc. 2004 12:04
Localisation : 35
Contact :

Message par carte-des-membres » jeu. 27 févr. 2014 11:04

Je m'occupe de le préfigurer correctement lorsque je créé les cartes, donc, hors migration de forum, c'est bon ;)

Feneck91
Messages : 4
Enregistré le : ven. 11 oct. 2013 3:12

Erreur d'alignement du au manque de ':' à la fin du texte

Message par Feneck91 » jeu. 27 mars 2014 17:02

Bon, une minuscule erreur d'affichage s'est glissée !

En effet, dans les fichier cdm.php (en français et en anglais) le champ CDM_MEMBERS_MAP est défini comme suit :

Code : Tout sélectionner

'CDM_MEMBERS_MAP' 		=> 'Carte des membres',
Ceci provoque une différence d'affichage lorsque l'on regarde un profile.
En effet, sous l'avatar on a un truc du genre :

Code : Tout sélectionner

Localisation: ma localisation
carte des membres <image>
Âge: 41
Emploi: mon emploi
Centres d’intérêt: Musique Danse Théâtre Chant Cinéma
En effet, carte des membres n'est pas aligné avec les autres car c'est le SEUL qui ne contient pas de ':' à la fin.

Patch :
Dans le fichier language/en/mods/cdm.php
Chercher :

Code : Tout sélectionner

	'CDM_MEMBERS_MAP' 		=> 'Members Map',
Remplacer par :

Code : Tout sélectionner

	'CDM_MEMBERS_MAP_HEADER'=> 'Members Map',
	'CDM_MEMBERS_MAP' 		=> 'Members Map:',
Dans le fichier language/fr/mods/cdm.php
Chercher :

Code : Tout sélectionner

	'CDM_MEMBERS_MAP' 		=> 'Carte des membres',
Remplacer par :

Code : Tout sélectionner

	'CDM_MEMBERS_MAP_HEADER'=> 'Carte des membres',
	'CDM_MEMBERS_MAP' 		=> 'Carte des membres:',
Dans styles/prosilver/template/overall_header.html
et styles/subsilver2/template/overall_header.html


Chercher :

Code : Tout sélectionner

L_CDM_MEMBERS_MAP
Remplacer par

Code : Tout sélectionner

L_CDM_MEMBERS_MAP_HEADER
Voilà, c'est corrigé.

papicx
Messages : 11
Enregistré le : jeu. 31 mai 2012 8:30

Re: [phpBB version 3.0] Indications d'intégration complète

Message par papicx » jeu. 10 nov. 2016 12:09

Bonjour à tous,
Je constate que des membres qui se sont localisés sur la carte, que l'icone sur notre forum ne se modifie plus.
il faut que je modifie leur compte sur la base de données pour mettre à jour leurs comptes.
Mon forum est en 3.0.14.
Une idée sur ce bug ?
Merci d’avance

Dehas
Messages : 16
Enregistré le : mar. 06 juin 2017 12:13

Re: [phpBB version 3.0] Indications d'intégration complète

Message par Dehas » mar. 15 août 2017 5:55

Je suis dans le même cas, je suis obligé de modifier dans la base de donnée, quelqu'un aurait une solution ??
Merci

Répondre